Incident - Mycalls - Assured
Incident Report for UKCloud Service
Resolved
This incident has been resolved.
Posted Oct 14, 2021 - 11:40 BST
Update
A fix has been implemented and we are monitoring the results.
Posted Oct 12, 2021 - 17:20 BST
Monitoring
We are investigating an issue affecting My Calls.

This incident is under investigation and updates will be provided when available.
Posted Oct 12, 2021 - 17:19 BST
This incident affected: UKCloud Portal (My Calls - Elevated).