Incident - Email and Collaboration, Elevated
Incident Report for UKCloud LTD
Resolved
The incident has now been resolved.
Posted 8 days ago. Jul 12, 2019 - 14:16 BST
Investigating
We have identified an issue with our Email and Collaboration service on our elevated platform.

We are currently investigating and will provide an update shortly.
Posted 8 days ago. Jul 12, 2019 - 12:59 BST
This incident affected: Email and Collaboration (PSN-P).